Jump to content
Sign in to follow this  
liberate

S13 rear lca's hitting back of brake discs?

Recommended Posts

Went to put my car back together tonight and ran into a problem.

 

The bottom rear of the brake disc hits the end of the lower control arm!

 

All this gear was on my car before, only things that have been changed are solid subframe bushes and oem replacement ball joints.

 

Have i missed something?? Any ideas??

Share this post


Link to post
Share on other sites

Only thng I can think of is the ball joint taper is skinnier so the lca moves up further n4 going tight?

Share this post


Link to post
Share on other sites

Thanks but na not it..

 

Standard lca's and standard knuckles. Checked the balljoints and they're the same too

Share this post


Link to post
Share on other sites

Not the best but here's a pic

image.jpg

Edited by liberate

Share this post


Link to post
Share on other sites

Looks cockeyed to me, and not seated as far in the knuckle as it should be

 

eplejus.com/200sx/balljoint2.jpg

Edited by blingcommander

Share this post


Link to post
Share on other sites

I will check the part number of the balljoints.

 

Passenger side is clearing by 5-10mm but the drivers side hits bad. Can't see why they're diffirent???

 

Is there meant to be anything between the hub and the disc?

Edited by liberate

Share this post


Link to post
Share on other sites

So tonight I tried standard lca+ balljoint off another car, same problem.

 

Standard suspention arms, same problem.

 

Current parts I'm running are..

S13 knuckle (same as 32 I thought)

R32 5stud hub

R32 disc

R32 caliper

S13 lca (same as 32 I thought)

 

So if everything is 32 gear why does it hit the lca?

 

Is it something to do with not using the drum brake setup? Even then though, the caliper bolts onto the disc so they must be in the right place

Share this post


Link to post
Share on other sites

Na it's still the standard knuckle. It seems ok, what part do you mean will brake?

Share this post


Link to post
Share on other sites

Doesn't look to be anything wrong with it.

 

I have another theory..

 

Yea, I've got another theory..

 

thought of something else I did since I pulled it all out.. Welded some big gussetts into the cradle! It would have got pretty hot, If it slightly warped it would explain why it was so difficult to get back in, would explain why the lca's are slightly harder to fit than you would think and would explain why one side has 10mm clearance and the other side hits?

Share this post


Link to post
Share on other sites

Im Gussing this is an S13? I just did my Subframe , All arm bushings and ball joints yesterday.. but i have an S15... mine looks way different to yours..

 

Definately something wrong, hope you got it sorted.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×